在http字段下加入一个map做匹配引导: map $http_user_agent $limit_bots {default 0;~*(baiduspider|google|soso|bing|yandex|sogou|yahoo|sohu-search|yodao|YoudaoBot|robozilla|msnbot|MJ12bot|NHN|Twiceler) 1;~*(AltaVista|Googlebot|Slu
正在浏览:Linux
Linux下查找指定时间更改的文件命令: find / -name *.php -mtime -1 查找根目下所有24小时内修改过的后缀名为php的文件。 find / -name *.java -mtime -1 |xargs ls -lta 查找根目录下所有24小时修改过的后
使用云锁PC端时,显示服务器不在线,无法进行管理。的提示。无法使用云锁提供的功能,但是实际上服务器运行正常。 发生这个错误通常是该服务器与云锁网络通信导致,解决办法也
把一个Thinkphp5开发的网站发布到客户的服务器上,结果除首页以外全部404,看了一下,客户的服务器是宝塔面板环境+nginx,那肯定是没开启pathinfo,其实在nginx上开始pathinfo很简单,但是
安装 Laravel 报错: the requested PHP extension mcrypt is missing from your system 一看就是没开启php的mcrypt扩展,结果我在php.ini中却没找到这个扩展。 于是就去找这个扩展想下载安装,后来发现原来
通过:apt-get update 和 apt-get upgrade 命令更新Ubuntu系统,均报错,具体错误信息: root@sd9f3fd:~/certbot# apt-get udpateE: Invalid operation udpateroot@sd9f3fd:~/certbot# apt-get udgradeE: Invalid operation udgrade 解决
宝塔面板nginx中安装的wordpress或者typecho程序如果启用隐藏index.php文件功能,会报404错误。 原因是宝塔在nginx中配置为默认走index.php规则,所以如果固定链接中去掉index.php的话,需要在
Linux后台进程死掉,会导致端口被占用。下面以端口8088被占用为例,列出详细解决过程。 1.查找被占用的端口 netstat -tlnnetstat -tln | grep 8088 netstat -tln 查看端口使用情况,而netstat -tln |
centos系统使用yum命令安装软件包时候报错: error: rpmdb: BDB0113 Thread/process 2229/140657048729600 failed: BDB1507 Thread died in Berkeley DB libraryerror: db5 error(-30973) from dbenv-failchk: BDB0087 DB_RUNRECOVERY: Fatal
ps -ef|grep keywords|grep -v grep|cut -c 9-15|xargs kill -9 运行上面这条命令会杀掉所有包含关键字keywords的进程,具体说明如下: cut -c 9-15 是截取输入行的第9个字符到第15个字符,而这正好是进程
vi/vim鼠标中键粘贴文本默认情况是自动缩进的,如果粘贴的是多行的文本,则第二行缩进1个tab,第三行缩进2个tab最后导致文本可读性减低了。 解决办法是粘贴之前设置为粘贴(paste)模式
CentOS网卡错误:Determining if ip address x.x.x.x is already in use for device eth0,解决办法如下: 在/etc/sysconfig/network-script/ifcfg-eth0 加入一行ARPCHECK=no 然后重启网卡即可。
Centos运行scp命令提示: bash: scp: command not found 解决办法: yum install openssh-clients
cat /etc/sysconfig/i18n 输入如下三行代码后保存即可解决linux中文乱码的问题 LANG=zh_CN.GB18030SUPPORTED=zh_CN.GB18030:zh_CN:zh:en_US.UTF-8:en_US:enSYSFONT=latarcyrheb-sun16
全新阿里云服务器安装宝塔面板后无法打开,经过检查发现阿里云服务器默认设置的安全组中屏蔽了8888端口,而宝塔面板的默认端口正好是8888,解决办法就是在阿里云管理后台中,新
打开宝塔面板回收站的方法: 点击左侧垂直菜单中的文件,点击打开页面的右上角回收站按钮即可。
磁盘重新挂载之前需要卸载挂载的时候有出现umount: /www: device is busy错误。表示进程占用导致无法挂载。 使用强制卸载挂载即可解决这个问题: umount -l /www
WordPress后台更新升级时由于网络原因可能会升级出错,导致升级页面空白,刷新后出现您确定要这样做?无法正常使用,解决办法如下: 1、下载最新版本WordPress安装包 wordpress中文官网
Linux 上的 find 命令是 findutil 软件包的一部分,一般已经默认集成在了几乎所有的发行版中。 find 命令有非常大的灵活性,可以向其指定丰富的搜索条件(如文件权限、属主、属组、文件
昨天升级了最新的Debian 10稳定版,结果php-fpm无法启动,报如下两个错误: Starting php-fpm /usr/local/php/sbin/php-fpm: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3 not found (required by /usr/loca



