正在浏览:Linux

今天在学习配置服务器的过程中,发现宝塔面板安装 nginx 后,默认的 error_log 配置如下: 在 error_log 的路径后,跟着一个单词 crit ,经过百度了解这是用来设置 error_log 记录的信息类型

nginx 的 error_log 文件错误类型如下(从左到右:debug 最详细 crit 最少) [ debug | info | notice | warn | error | crit ] 示例: error_log /www/wwwlogs/www.02405.com.error.log notice; #显示最低级别的错误信息。

Nginx服务器开启 rewrite 功能后并未生效,想调试却没找到日志文件,因此需要开启 Nginx 的 rewrite 日志功能,具体步骤如下(以宝塔示例): 一、修改日志级别 设置 nginx 配置文件中的错

Laravel队列在服务端推荐使用Supervisor监控队列进程,如果服务器使用了宝塔面板的话,那么我们可以非常方便的启用并配置Supervisor,宝塔面板Laravel队列的Supervisor配置步骤如下: 1.安装

Apache服务器设置网站只允许指定IP访问的方法(以centos 7.0示例): 打开apache的配置文件:httpd.conf,找到想要设置的网站的配置信息,添加如下代码: #禁止所有IP访问Deny From All#允许1

在linux下使用cp命令复制文件时,有时会遇到cp: omitting directory……错误,这个错误是因为我们要复制的文件夹下还有文件夹,解决办法就是采用递归拷贝,也就是给cp命令加上-r参数。

今天发现我的debian服务器居然不能使用dig和nslookup命令,具体如下: root@jp:~# dig-bash: dig: command not foundroot@jp:~# nslookup-bash: nslookup: command not found 这一看就是没安装对应的软件包,解决放大

CentOS 7修改服务器主机名称: 1、临时生效 hostname xxx 修改完成后,只是临时生效,重启服务器后恢复原名。 2、永久生效 2.1 通过 hostnamectl 服务修改,修改后立即生效: hostnamectl set-ho

CentOS 7处于稳定考虑,默认支持的软件版本都比较低,比如默认仅支持OpenSSL 1.0.2版本,因此没办法原生支持很多新版本的特性。事实上,OpenSSL已经官方淘汰了老版本的1.0.2支持。因此大

Linux批量替换txt文件内容的方法,切换到要替换的文件所在目录,执行下面的命令: find . -name *.txt -print | xargs perl -pi -e s/www.02405.com/www.zaoandianzishu.com/g s/要搜索的字符串/要替换成的字符

systemctl stop firewalldsystemctl mask firewalldyum install iptables-services -ysystemctl enable iptablesecho net.ipv4.ip_forward = 1 | tee -a /etc/sysctl.confsysctl -piptables -A FORWARD -d 10.20.0.1 -i eth0 -p tcp -m tcp –dport 443 -j AC

1.安装KVM 检查环境是否支持KVM cat /proc/cpuinfo | egrep vmx|svm 若环境支持则有内容返回 关闭SELinux vi /etc/sysconfig/selinux 修改 SELinux=enforcing 为 SELinux=disabled 使用yum软件包管理器安装kvm yum -y in

id_rsa增加密码: openssl rsa -aes256 -in your.key -out your.encrypted.key id_rsa移除密码: openssl rsa -in your.key -out your.open.key 说明:id_rsa文件需要400的权限, 否则不能使用.