前端技术 手机教程
程序开发 平面动画
系统软件 CMS教程
CMS教程 在线手册
资源下载 网络安全
精准搜索请尝试:精确搜索

Error: php55w-common conflicts with php-common-5.3.3-48.el6_8.x86_64

2017-09-21 14:38:48 来源:原创 作者:寂静的神经

最近需要在一台centos6.5服务器上部署thinkphp5开发的网站程序,部署后网站无法正常运行,经过检查发现服务器上的php版本为5.3.3,而thinkphp5要求的最低php版本为5.4。

想着php5.3确实有点老旧了,就直接卸载了php5.3然后使用rpm方式重新安装了php5.5,然而在运行网站时又提示“Class 'PDO' not found”错误,经过检查是因为刚才安装php5.5时没有安装php-pdo和php-mysql两个包。

直接rpm安装,命令如下:


yum install php-pdo
yum install php-mysql

本以为万事大吉,终于搞定,没成想两条命令均报错:Error: php55w-common conflicts with php-common-5.3.3-48.el6_8.x86_64

猜想应该是php5.3.3的某些配置没清理干净,最终解决方案是指定安装5.5版本的php-pdo以及php-mysql,命令如下:


yum install php55w-pdo
yum install php55w-mysql

OK,顺利完成安装,重启apache,网站正确运行。

如果你是安装其他php扩展包出现的这个错误提示,也可以以此类推,安装指定版本的包即可。

本文关键词:error php55w php-common

相关文章

零五网,分享IT知识,国内顶级IT知识门户网站。

Copyright (C) www.02405.com, All Rights Reserved.

零五网 版权所有 辽ICP备13002105号-1