?php// $string: 明文 或 密文// $operation:DECODE表示解密,其它表示加密// $key: 密匙// $expiry:密文有效期function authcode($string, $operation = DECODE, $key = , $expiry = 0) { // 动态密匙长度,相同的明文
正在浏览:CMS教程
最近发现我的WordPress博客在媒体中无法编辑图片,经过检查返现问题是没安装php的php70w-pecl-imagick扩展。 解决办法就是安装这个扩展,然后重启php-fpm即可。
1.帝国CMS灵动标签中截取字符串尾部指定位数的方法: 在帝国CMS中我们可以使用灵动标签默认的截取函数esub来实现截取字符串尾部指定位数的功能,示例如下: [e:loop={select * from phome
最近做了一个wordpress网站,向服务器发布网站时,导入数据过程中报错:#1273 Unknown collation:utf8mb4_unicode_ci,这个错误一看就涉及到了mysql编码问题,查看了一下虚拟主机上的mysql版本:
DedeCMS中直接通过flink标签调用友情链接输出的代码中会包含li标签,如下: 调用友情链接: {dede:flink row=24/} 输出代码: lia href=https://www.kanbang.cc看帮网/a/lilia href=http://www.02405.com零五科技
ECShop伪静态规则(nginx): if (!-e $request_filename){rewrite ^/index\.html /index.php last;rewrite ^/category$ /index.php last;rewrite ^/feed-c([0-9]+)\.xml$ /feed.php?cat=$1 last;rewrite ^/feed-b([0-9]+)\.xml$ /feed.php?brand=$1 last
WordPress伪静态规则(nginx): location /{ try_files $uri $uri/ /index.php?$args;}rewrite /wp-admin$ $scheme://$host$uri/ permanent;
DedeCMS伪静态规则(nginx): rewrite ^/list-([0-9]+)\.html$ /plus/list.php?tid=$1 last;rewrite ^/list-([0-9]+)-([0-9]+)-([0-9]+)\.html$ /plus/list.php?tid=$1totalresult=$2PageNo=$3 last;rewrite ^/view-([0-9]+)-1\.html$ /plus/view.php?ar
帝国cms7.5伪静态规则(nginx): rewrite ^([^\.]*)/listinfo-(.+?)-(.+?)\.html$ $1/e/action/ListInfo/index.php?classid=$2page=$3 last;rewrite ^([^\.]*)/showinfo-(.+?)-(.+?)-(.+?)\.html$ $1/e/action/ShowInfo.php?classid=$2id=$3page=$4 la
飞飞cms数据库配置文件:Runtime/Conf/config.php,更换网站服务器/空间后要在这个文件中重新配置数据库信息。 db_host:数据库地址 db_name:数据库名称 db_user:数据库用户名 db_pwd:数据库密
DedeCMS后台登录页面内置了官方的广告,如下图所示,那么要怎么去掉DedeCMS后台登录页面广告呢? DedeCMS去掉后台登录页面广告的办法: 打开dede/templets/login.htm文件,dede为你的后台目录
DedeCMS后台模块管理空白不显示列表的解决办法: 备份后打开/dede/module_main.php文件(其中dede为您的后台管理目录),注释或删除以下两行代码: 大约第91行代码: $modules_remote = $dm-gt;GetMo
DedeCMS内置的自定义函数定义文件为:include/extend.fuc.php,我们可以通过这个文件来新增自定义函数,比如我们新增一个自定义函数,用来返回一个随机作者: function randw($val){$writers = a
DEDECMS后台修改模板代码后保存报错:Error:no csrf hash code!,解决办法如下: 1.通过生成-更新系统缓存,清理系统缓存。 2.清理浏览器缓存 一般来说通过以上两种方法就能解决这个问题,
在使用dedecms进行二次开发时,经常要用到自定义字段,不过在内容模型中新增自定义字段时我已经选择了使字段可以在列表的底层模板中获得,但是在{dedearclist}中调用仍然不显示任何
使用dedecms的朋友在创建好网站后会发现网站底部会有power by dedecms字样的版权提示,在这里零五科技呼吁大家保留这个版权提示。那么强迫症选手要怎么去掉power by dedecms信息呢?以下两
DedeCMS5.7中的dede:channel标签不支持调用栏目简介description及关键词keywords,我们可以通过修改channel标签源文件来调用栏目简介description及关键词keywords,具体方法如下: 打开include\taglib\c
在PHP5.3以上版本安装并运行ECShop时,安装完毕后打开前台页面时,程序会报错:Strict Standards: Only variables should be passed by reference in D:\phpStudy\WWW\public\shop\includes\cls_template.php on line 422,出
在安装ECShop V2.7.3版本时,安装程序会提示错误,错误信息:Strict Standards: Non-static method cls_image::gd_version() should not be called statically in D:\phpstudy\WWW\shop\install\\includes\lib_installer.php on line 3
DedeCMS中的include/extend.func.php文件就是预留的自定义函数文件,将自定义函数写到这个文件中即可在DedeCMS调用该函数,下面举例说明: 1.打开include/extend.func.php文件,在文件的最后加入如



