前端技术 手机教程
程序开发 平面动画
系统软件 运营推广
CMS教程 在线手册
资源下载 网络安全
精准搜索请尝试:精确搜索

Centos 7提示ImportError: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found错误的解决办法

2020-11-24 16:42:58 来源:原创 作者:寂静的神经

Centos 7提示ImportError: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found错误,原因是Centos 7默认的CXXABI版本为1.3.7,需要升级版本,具体操作如下:

1.通过下面的命令查看/usr/lib64/下的动态库版本


strings /usr/lib64/libstdc++.so.6 | grep 'CXXABI'

查询结果动态库的版本就到1.3.7。

2.从网上下载所需要的libstdc++.so.6.0.22版本,为了方便可以从本站直接下载:libstdc++.so.6.0

3.将下载好的libstdc++.so.6.0.22解压缩后上传到Centos 7系统的/usr/lib64目录下。

4.切换到/usr/lib64目录。


cd /usr/lib64

5.删除原来的libstdc++.so.6软连接。


rm -rf libstdc++.so.6

6.新建软连接。


ln -s libstdc++.so.6.0.22 libstdc++.so.6

 

分享到:
本文关键词:CentOS libstdc++ CXXABI

相关文章

零五科技,分享IT知识,国内顶级IT知识门户网站。

Copyright (C) www.02405.com, All Rights Reserved.

零五科技 版权所有 辽ICP备13002105号-1