前端技术 手机教程
程序开发 平面动画
系统软件 运营推广
CMS教程 在线手册
资源下载 网络安全
精准搜索请尝试:精确搜索

Laravel框架Warning: require(../vendor/autoload.php): failed to open stream: No such file or directory in .../autoload.php on line 17错误的解决办法

2018-07-12 14:07:44 来源:原创 作者:寂静的神经

最近在学习Laravel框架,在phpstudy下使用composer+laravel安装器的方式安装了Laravel,但是访问的时候报错:

Warning: require(D:\phpstudy\WWW\public\myblog\bootstrap/../vendor/autoload.php): failed to open stream: No such file or directory in .../autoload.php on line 17

通过百度了解到在项目根目录运行composer update命令可以解决这个问题。

但是我在运行composer update时报错,截图如下:

很明显,错误表示最新版本的Laravel5.6版本需要php7.1.3以上版本,但是我的php是7.0.12。

而通过Laravel安装器安装Laravel框架时无法指定具体版本,最终解决办法就是删掉项目文件,通过Composer Create-Project命令指定版本安装Laravel。

composer create-project --prefer-dist laravel/laravel myblog 5.5.*
分享到:
本文关键词:laravel Waring require

相关文章

零五科技,分享IT知识,国内顶级IT知识门户网站。

Copyright (C) www.02405.com, All Rights Reserved.

零五科技 版权所有 辽ICP备13002105号-1

//百度 //cnzz